package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)S(?<s>[0-9]+) ?\(([0-9]{1,})*\)`)
var str = `American Dad S01 (1).mkv
American Dad S05 (12).mkv`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}