re = /S(?<s>[0-9]+) ?\(([0-9]{1,})*\)/m
str = 'American Dad S01 (1).mkv
American Dad S05 (12).mkv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end