$re = '/S(?<s>[0-9]+) ?\(([0-9]{1,})*\)/m';
$str = 'American Dad S01 (1).mkv
American Dad S05 (12).mkv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);