using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<@viktor>(?:<@)?+|\G(?<!^))(?:(?!<@).)*?:apple:";
string input = @"I had :apple::apple::apple::apple: :apple:<@Viktor><Kate>took:apple::apple: and later <@viktor> took again:apple:but not <@kate>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}