use strict;
my $str = 'I had :apple::apple::apple::apple: :apple:<@Viktor><Kate>took:apple::apple: and later <@viktor> took again:apple:but not <@kate>';
my $regex = qr/(?:<@viktor>(?:<@)?+|\G(?<!^))(?:(?!<@).)*?:apple:/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}