const regex = /(?:<@viktor>(?:<@)?+|\G(?<!^))(?:(?!<@).)*?:apple:/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<@viktor>(?:<@)?+|\\G(?<!^))(?:(?!<@).)*?:apple:', 'gmi')
const str = `I had :apple::apple::apple::apple: :apple:<@Viktor><Kate>took:apple::apple: and later <@viktor> took again:apple:but not <@kate>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}