$re = '/(?:<@viktor>(?:<@)?+|\G(?<!^))(?:(?!<@).)*?:apple:/mi';
$str = 'I had :apple::apple::apple::apple: :apple:<@Viktor><Kate>took:apple::apple: and later <@viktor> took again:apple:but not <@kate>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);