#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+)\s+(\S+)\s+(\S+)\s+(\S+)\s+(\S.*)$"
Local $sString = " 1 50 4294967295 connected Loopback Pseudo-Interface 1" & @CRLF & _
" 12 25 1500 connected Wireless Network Connection" & @CRLF & _
" 11 10 1500 connected Local Area Connection" & @CRLF & _
" 14 40 1500 disconnected Bluetooth Network Connection" & @CRLF & _
" 21 20 1500 connected VMware Network Adapter VMnet1" & @CRLF & _
" 22 20 1500 connected VMware Network Adapter VMnet8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")