package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)\s+(\S+)\s+(\S+)\s+(\S+)\s+(\S.*)$`)
var str = ` 1 50 4294967295 connected Loopback Pseudo-Interface 1
12 25 1500 connected Wireless Network Connection
11 10 1500 connected Local Area Connection
14 40 1500 disconnected Bluetooth Network Connection
21 20 1500 connected VMware Network Adapter VMnet1
22 20 1500 connected VMware Network Adapter VMnet8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}