# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d+)\s+(\S+)\s+(\S+)\s+(\S+)\s+(\S.*)$"
test_str = (" 1 50 4294967295 connected Loopback Pseudo-Interface 1\n"
" 12 25 1500 connected Wireless Network Connection\n"
" 11 10 1500 connected Local Area Connection\n"
" 14 40 1500 disconnected Bluetooth Network Connection\n"
" 21 20 1500 connected VMware Network Adapter VMnet1\n"
" 22 20 1500 connected VMware Network Adapter VMnet8")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.