using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\s+(\S+)\s+(\S+)\s+(\S+)\s+(\S.*)$";
string input = @" 1 50 4294967295 connected Loopback Pseudo-Interface 1
12 25 1500 connected Wireless Network Connection
11 10 1500 connected Local Area Connection
14 40 1500 disconnected Bluetooth Network Connection
21 20 1500 connected VMware Network Adapter VMnet1
22 20 1500 connected VMware Network Adapter VMnet8";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}