import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\{]%\\s*?\\b([^\\}]*start[^\\}]*)\\b\\s*?%[\\}]\\s*?\\b(.*?)\\b\\s*?[\\{]%\\s*\\b([^\\}]*end[^\\}]*)\\b\\s*%[\\}]";
final String string = "{% start %}some random text{% end %}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}