re = /[{]%\s*?\b([^}]*start[^}]*)\b\s*?%[}]\s*?\b(.*?)\b\s*?[{]%\s*\b([^}]*end[^}]*)\b\s*%[}]/
str = '{% start %}some random text{% end %}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end