const regex = /[{]%\s*?\b([^}]*start[^}]*)\b\s*?%[}]\s*?\b(.*?)\b\s*?[{]%\s*\b([^}]*end[^}]*)\b\s*%[}]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[{]%\\s*?\\b([^}]*start[^}]*)\\b\\s*?%[}]\\s*?\\b(.*?)\\b\\s*?[{]%\\s*\\b([^}]*end[^}]*)\\b\\s*%[}]', '')
const str = `{% start %}some random text{% end %}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}