using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z0-9_\-%\/\/.]+\.)(jpe?g|gif|png)$";
string input = @"image.png
image1.png
image-1.png
error.jpg"" onerror=""alert('XSS')"" foo=""image.jp";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}