$re = '/^([a-z0-9_\-%\/\/.]+\.)(jpe?g|gif|png)$/m';
$str = 'image.png
image1.png
image-1.png
error.jpg" onerror="alert(\'XSS\')" foo="image.jp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);