// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-z0-9_\-%\/\/.]+\.)(jpe?g|gif|png)$").unwrap();
let string = "image.png
image1.png
image-1.png
error.jpg\" onerror=\"alert('XSS')\" foo=\"image.jp";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}