package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-z0-9_\-%\/\/.]+\.)(jpe?g|gif|png)$`)
var str = `image.png
image1.png
image-1.png
error.jpg" onerror="alert('XSS')" foo="image.jp`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}