#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?<=\s)'([^']+)'(?=\s))"
Local $sString = "I'm one of the persons' stackoverflow don't th'em said, 'hey what' I'll handle it."
Local $sSubst = ""\2""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)