re = /((?<=\s)'([^']+)'(?=\s))/
str = 'I\'m one of the persons\' stackoverflow don\'t th\'em said, \'hey what\' I\'ll handle it.'
subst = '"\\2"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result