const regex = new RegExp('((?<=\\s)\\'([^\\']+)\\'(?=\\s))', 'g')
const str = `I'm one of the persons' stackoverflow don't th'em said, 'hey what' I'll handle it.`;
const subst = `"\2"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);