using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=\s)'([^']+)'(?=\s))";
string substitution = @"""\2""";
string input = @"I'm one of the persons' stackoverflow don't th'em said, 'hey what' I'll handle it.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}