package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+(?:\s*\w\b)?)[^\d]+\d{5}[^\d]+$`)
var str = `32 Rue Jean Jaures 69000 Lyon
Bâtiment 1 32 Rue Jean Jaures 69000 Lyon
32 B Jean Jaures 69000 Lyon
Bâtiment 1 32 B Rue Jean Jaures 69000 Lyon`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}