re = /(\d+(?:\s*\w\b)?)[^\d]+\d{5}[^\d]+$/m
str = '32 Rue Jean Jaures 69000 Lyon
Bâtiment 1 32 Rue Jean Jaures 69000 Lyon
32 B Jean Jaures 69000 Lyon
Bâtiment 1 32 B Rue Jean Jaures 69000 Lyon'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end