const regex = /(\d+(?:\s*\w\b)?)[^\d]+\d{5}[^\d]+$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+(?:\\s*\\w\\b)?)[^\\d]+\\d{5}[^\\d]+$', 'mg')
const str = `32 Rue Jean Jaures 69000 Lyon
Bâtiment 1 32 Rue Jean Jaures 69000 Lyon
32 B Jean Jaures 69000 Lyon
Bâtiment 1 32 B Rue Jean Jaures 69000 Lyon`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}