import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<amount>[\\d,.]+)(?<provider>Spotify|Netflix|Amazon)\\s*$";
final String string = "DateAmountDescription \n"
+ "24-01-2016$ 14,99Spotify \n"
+ "23-01-2016$ 10,50Netflix\n"
+ "23-01-2016$ 5,50Amazon";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}