re = /(?<amount>[\d,.]+)(?<provider>Spotify|Netflix|Amazon)\s*$/m
str = 'DateAmountDescription
24-01-2016$ 14,99Spotify
23-01-2016$ 10,50Netflix
23-01-2016$ 5,50Amazon'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end