$re = '/(?<amount>[\d,.]+)(?<provider>Spotify|Netflix|Amazon)\s*$/m';
$str = 'DateAmountDescription
24-01-2016$ 14,99Spotify
23-01-2016$ 10,50Netflix
23-01-2016$ 5,50Amazon';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);