const regex = /(?<amount>[\d,.]+)(?<provider>Spotify|Netflix|Amazon)\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<amount>[\\d,.]+)(?<provider>Spotify|Netflix|Amazon)\\s*$', 'gm')
const str = `DateAmountDescription
24-01-2016\$ 14,99Spotify
23-01-2016\$ 10,50Netflix
23-01-2016\$ 5,50Amazon`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}