package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d(?:\.?\d\d|\d\.?\d)$`)
var str = `333
333
33.1
3.33
3.3.
3.333
3333.
3..
.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}