import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d(?:\\.?\\d\\d|\\d\\.?\\d)$";
final String string = "333\n"
+ "333\n"
+ "33.1\n"
+ "3.33\n\n"
+ "3.3.\n"
+ "3.333\n"
+ "3333.\n"
+ "3..\n"
+ ".";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}