$re = '/^\d(?:\.?\d\d|\d\.?\d)$/m';
$str = '333
333
33.1
3.33
3.3.
3.333
3333.
3..
.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);