// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d(?:\.?\d\d|\d\.?\d)$").unwrap();
let string = "333
333
33.1
3.33
3.3.
3.333
3333.
3..
.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}