re = /(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})+/m
str = '"badips":["123.456.789.12","123.456.789.13","123.456.789.14"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end