// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})+").unwrap();
let string = "\"badips\":[\"123.456.789.12\",\"123.456.789.13\",\"123.456.789.14\"]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}