use strict;
my $str = 'Dude
What';
my $regex = qr/(.+)/p;
my $subst = '@Column(name="\\1")';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";