package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([\w]+\/){3})([^\/]+)(\/.+)`)
var str = `res/icons/android/quickshop/icon-36-ldpi.png
res/icons/android/quickshop/icon-48-mdpi.png
res/icons/ios/quickshop/icon-72-hdpi.png
res/icons/ios/quickshop/icon-96-xhdpi.png`
var substitution = "\1homecenter\4"
fmt.Println(re.ReplaceAllString(str, substitution))
}