use strict;
my $str = 'res/icons/android/quickshop/icon-36-ldpi.png
res/icons/android/quickshop/icon-48-mdpi.png
res/icons/ios/quickshop/icon-72-hdpi.png
res/icons/ios/quickshop/icon-96-xhdpi.png';
my $regex = qr/(([\w]+\/){3})([^\/]+)(\/.+)/mp;
my $subst = '\\1homecenter\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";