$re = '/(([\w]+\/){3})([^\/]+)(\/.+)/m';
$str = 'res/icons/android/quickshop/icon-36-ldpi.png
res/icons/android/quickshop/icon-48-mdpi.png
res/icons/ios/quickshop/icon-72-hdpi.png
res/icons/ios/quickshop/icon-96-xhdpi.png';
$subst = "\1homecenter\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;