re = /(([\w]+\/){3})([^\/]+)(\/.+)/m
str = 'res/icons/android/quickshop/icon-36-ldpi.png
res/icons/android/quickshop/icon-48-mdpi.png
res/icons/ios/quickshop/icon-72-hdpi.png
res/icons/ios/quickshop/icon-96-xhdpi.png'
subst = '\\1homecenter\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result