#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "@(?={)([^}{]+|{((?1)*)})"
Local $sString = "@{" & @CRLF & _
"" & @CRLF & _
" This is some text" & @CRLF & _
"" & @CRLF & _
" {" & @CRLF & _
" This another text" & @CRLF & _
"" & @CRLF & _
" {" & @CRLF & _
" inner text" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"@{" & @CRLF & _
" this is text2" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"another text that does not match the regex" & @CRLF & _
"" & @CRLF & _
"@{" & @CRLF & _
" this is another text" & @CRLF & _
" {" & @CRLF & _
" another inner text" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")