import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@(?=\\{)([^\\}\\{]+|\\{((?1)*)\\})";
final String string = "@{\n\n"
+ " This is some text\n\n"
+ " {\n"
+ " This another text\n\n"
+ " {\n"
+ " inner text\n"
+ " }\n"
+ " }\n\n"
+ "}\n\n"
+ "@{\n"
+ " this is text2\n"
+ "}\n\n"
+ "another text that does not match the regex\n\n"
+ "@{\n"
+ " this is another text\n"
+ " {\n"
+ " another inner text\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}