re = /@(?={)([^}{]+|{((?1)*)})/
str = '@{
This is some text
{
This another text
{
inner text
}
}
}
@{
this is text2
}
another text that does not match the regex
@{
this is another text
{
another inner text
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end