using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@(?={)([^}{]+|{((?1)*)})";
string input = @"@{
This is some text
{
This another text
{
inner text
}
}
}
@{
this is text2
}
another text that does not match the regex
@{
this is another text
{
another inner text
}
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}