using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|&)value=([^&]*)";
string input = @"value=8kadctgwqqe0&value=8kaczvfgoyrs&value=8kwkgz2ysm1i";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}