$re = '/(?:^|&)value=([^&]*)/';
$str = 'value=8kadctgwqqe0&value=8kaczvfgoyrs&value=8kwkgz2ysm1i';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);