re = /(?:^|&)value=([^&]*)/
str = 'value=8kadctgwqqe0&value=8kaczvfgoyrs&value=8kwkgz2ysm1i'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end