package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^|&)value=([^&]*)`)
var str = `value=8kadctgwqqe0&value=8kaczvfgoyrs&value=8kwkgz2ysm1i`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}