package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|\s|[^\w$])([a-z_$][a-zA-Z]*[A-Z][a-zA-Z]*)`)
var str = `someCamelCasedString & _someCamelCasedString & $someCamelCasedString. Th
: Foo._someCamelCasedString.bar or Foo[_someCamelCasedString].bar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}