import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\s|[^\\w$])([a-z_$][a-zA-Z]*[A-Z][a-zA-Z]*)";
final String string = "someCamelCasedString & _someCamelCasedString & $someCamelCasedString. Th\n"
+ ": Foo._someCamelCasedString.bar or Foo[_someCamelCasedString].bar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}